Tuesday, August 31, 2010

Oh dear.....I've bought another watch! Bellmatic 4006-6030.

(Click on any image to see a much larger shot)
I couldn't resist this "Belle" when I saw it advertised for sale on the Seiko & Citizen Watch forum. 
It wasn't specifically because the case is actually gold-plated, not just "gold-tone", but was due more to the fact that the bracelet is an original "coffin" Seiko model, with alternating gold-tone and stainless-steel link sections. These are not common.

So, as I only have one Bellmatic left in my collection, I thought that this would be a nice addition.

The watch arrived today and once the date and time were set and the watch given a couple of gentle shakes, away she went and now, some 10 hours later, is still running sweetly.

The dial, crystal, hands, case and bracelet are in very good condition and the entire item makes for a very handsome timepiece that just screams "1970s"!

My thanks to the gentleman in the USA from whom I bought the "Belle"; I'm delighted with it.

Thursday, August 12, 2010

Another 7T59 comes along.

SOLD April 2015

Just when you thought it was safe to go back into the water..........another watch is bought and added to the collection!
Say hello to a 7T59-6A00 from October 1991.

This little beauty was advertised on eBay as cosmetically excellent but running erratically - "stops and starts" was the term used, plus "good for parts". And that was the reason I bought it, thinking that as the case and bracelet were in excellent shape I could transplant the movement from my other, somewhat less pristine, 7T59 (see previous blog entry - December 6th. 2009).

However, after I opened the parcel this morning, adjusted the date and time (the watch was stopped), it has kept running. As I type this, more than 10 hours have elapsed and the 7T is running nicely, keeping good time.

I am hopeful that whatever the malfunction might be (or have been) can be easily corrected so now I will just wait and see if it stops and, when or if it does, then I'll have it looked at.
In the meantime, it will provide company for it's worse-for-wear sibling!


UPDATE: Sunday 15th. August.
It did stop....about 14 hours after I initially set it running.
So what I did was to remove the case-back, the internal shroud which acts as a positive contact on the battery and then the battery from its little hole.
I checked the voltage, cleaned the battery surfaces and also made sure that the negative contact in the bottom of the socket was okay, reassembled and then, following the instructions, shorted the positive of the battery to a point marked 'AC'. The back-plate was then screwed back on.
After going through the sequence for resetting the time, the watch has now been running for more than a day so I am hopeful that it has now returned to its normal state. We'll see.


UPDATE to the UPDATE - Monday 28th. November 2011
I'm pleased to report that this watch has been running constantly, keeping excellent time, for over a month now.
I had removed the battery late last year, then shelved the watch.
This weekend I decided to see if I could get the 7T59 operating reliably, so did nothing more than clean contacts, lightly (very lightly) lubricate the moving bits and then bought and inserted a fresh battery.


Hey Presto!
Running beautifully ever since.